use strict;
my $str = 'extends standard
block head
<title>title</title>
<meta name="description" content="A wonderful thing.">
block body
<h1>Title</h1>
<p>A wonderful paragraph...</p>
block scripts
<script src="/javascritps/html5shiv.js"></script>';
my $regex = qr/(?<=^block )\w+\n/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}