#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mix)(?<Test><(?<Node>\S+)(>\s*<\/\k<Node>>|\s*\/>))|(?<test2><(?<Outer>\S+)>\s+((?&Test)|(?&test2)*" & @CRLF & _
")\s+<\/\k<Outer>>)"
Local $sString = "<root>" & @CRLF & _
"<tag1>Good</tag1>" & @CRLF & _
"<tag2 element="Good"></tag2>" & @CRLF & _
"<tag3 element="Good" />" & @CRLF & _
"<tag4></tag4>" & @CRLF & _
"<tag13>" & @CRLF & _
"</tag13>" & @CRLF & _
"<tag5 />" & @CRLF & _
"<tag6/>" & @CRLF & _
"<tag7>" & @CRLF & _
" <tag7.1>good</tag7.1>" & @CRLF & _
"</tag7>" & @CRLF & _
"<tag8>" & @CRLF & _
" <tag8.1></tag8.1>" & @CRLF & _
"</tag8>" & @CRLF & _
"<tag9>" & @CRLF & _
" <tag9.1 />" & @CRLF & _
"</tag9>" & @CRLF & _
"<tag10>" & @CRLF & _
" <tag10.1/>" & @CRLF & _
"</tag10>" & @CRLF & _
"<tag10>" & @CRLF & _
" <tag10.1>Wel iets</tag10.1>" & @CRLF & _
"</tag10>" & @CRLF & _
"<tag11>" & @CRLF & _
" <tag11.1 element="Good"/>" & @CRLF & _
"</tag11>" & @CRLF & _
"<tag12>" & @CRLF & _
" <tag12.1></tag12.1>" & @CRLF & _
" <tag12.2>" & @CRLF & _
" <tag12.2.1></tag12.2.1>" & @CRLF & _
" </tag12.2>" & @CRLF & _
"</tag12>" & @CRLF & _
"</root>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")