// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mix)(?<Test><(?<Node>\S+)(>\s*<\/\k<Node>>|\s*\/>))|(?<test2><(?<Outer>\S+)>\s+((?&Test)|(?&test2)*
)\s+<\/\k<Outer>>)").unwrap();
let string = "<root>
<tag1>Good</tag1>
<tag2 element=\"Good\"></tag2>
<tag3 element=\"Good\" />
<tag4></tag4>
<tag13>
</tag13>
<tag5 />
<tag6/>
<tag7>
<tag7.1>good</tag7.1>
</tag7>
<tag8>
<tag8.1></tag8.1>
</tag8>
<tag9>
<tag9.1 />
</tag9>
<tag10>
<tag10.1/>
</tag10>
<tag10>
<tag10.1>Wel iets</tag10.1>
</tag10>
<tag11>
<tag11.1 element=\"Good\"/>
</tag11>
<tag12>
<tag12.1></tag12.1>
<tag12.2>
<tag12.2.1></tag12.2.1>
</tag12.2>
</tag12>
</root>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}