re = /(?<Test><(?<Node>\S+)(>\s*<\/\k<Node>>|\s*\/>))|(?<test2><(?<Outer>\S+)>\s+((?&Test)|(?&test2)*
)\s+<\/\k<Outer>>)/mix
str = '<root>
<tag1>Good</tag1>
<tag2 element="Good"></tag2>
<tag3 element="Good" />
<tag4></tag4>
<tag13>
</tag13>
<tag5 />
<tag6/>
<tag7>
<tag7.1>good</tag7.1>
</tag7>
<tag8>
<tag8.1></tag8.1>
</tag8>
<tag9>
<tag9.1 />
</tag9>
<tag10>
<tag10.1/>
</tag10>
<tag10>
<tag10.1>Wel iets</tag10.1>
</tag10>
<tag11>
<tag11.1 element="Good"/>
</tag11>
<tag12>
<tag12.1></tag12.1>
<tag12.2>
<tag12.2.1></tag12.2.1>
</tag12.2>
</tag12>
</root>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end