import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<Test><(?<Node>\\S+)(>\\s*<\\/\\k<Node>>|\\s*\\/>))|(?<test2><(?<Outer>\\S+)>\\s+((?&Test)|(?&test2)*\n"
+ ")\\s+<\\/\\k<Outer>>)";
final String string = "<root>\n"
+ "<tag1>Good</tag1>\n"
+ "<tag2 element=\"Good\"></tag2>\n"
+ "<tag3 element=\"Good\" />\n"
+ "<tag4></tag4>\n"
+ "<tag13>\n"
+ "</tag13>\n"
+ "<tag5 />\n"
+ "<tag6/>\n"
+ "<tag7>\n"
+ " <tag7.1>good</tag7.1>\n"
+ "</tag7>\n"
+ "<tag8>\n"
+ " <tag8.1></tag8.1>\n"
+ "</tag8>\n"
+ "<tag9>\n"
+ " <tag9.1 />\n"
+ "</tag9>\n"
+ "<tag10>\n"
+ " <tag10.1/>\n"
+ "</tag10>\n"
+ "<tag10>\n"
+ " <tag10.1>Wel iets</tag10.1>\n"
+ "</tag10>\n"
+ "<tag11>\n"
+ " <tag11.1 element=\"Good\"/>\n"
+ "</tag11>\n"
+ "<tag12>\n"
+ " <tag12.1></tag12.1>\n"
+ " <tag12.2>\n"
+ " <tag12.2.1></tag12.2.1>\n"
+ " </tag12.2>\n"
+ "</tag12>\n"
+ "</root>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}