using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<Test><(?<Node>\S+)(>\s*<\/\k<Node>>|\s*\/>))|(?<test2><(?<Outer>\S+)>\s+((?&Test)|(?&test2)*
)\s+<\/\k<Outer>>)";
string input = @"<root>
<tag1>Good</tag1>
<tag2 element=""Good""></tag2>
<tag3 element=""Good"" />
<tag4></tag4>
<tag13>
</tag13>
<tag5 />
<tag6/>
<tag7>
<tag7.1>good</tag7.1>
</tag7>
<tag8>
<tag8.1></tag8.1>
</tag8>
<tag9>
<tag9.1 />
</tag9>
<tag10>
<tag10.1/>
</tag10>
<tag10>
<tag10.1>Wel iets</tag10.1>
</tag10>
<tag11>
<tag11.1 element=""Good""/>
</tag11>
<tag12>
<tag12.1></tag12.1>
<tag12.2>
<tag12.2.1></tag12.2.1>
</tag12.2>
</tag12>
</root>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}