using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bsection \d+ (?:(?!\bsection \d+).)*?(?:19|20)\d{2}\b";
string input = @"section 1 bar bar section 2 foo 2019 foo section 3 bar 2021 bar end";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}