const regex = /\bsection \d+ (?:(?!\bsection \d+).)*?(?:19|20)\d{2}\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bsection \\d+ (?:(?!\\bsection \\d+).)*?(?:19|20)\\d{2}\\b', 'gm')
const str = `section 1 bar bar section 2 foo 2019 foo section 3 bar 2021 bar end`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}