$re = '/\bsection \d+ (?:(?!\bsection \d+).)*?(?:19|20)\d{2}\b/m';
$str = 'section 1 bar bar section 2 foo 2019 foo section 3 bar 2021 bar end';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);