import re
regex = re.compile(r"\bsection \d+ (?:(?!\bsection \d+).)*?(?:19|20)\d{2}\b", flags=re.MULTILINE)
test_str = "section 1 bar bar section 2 foo 2019 foo section 3 bar 2021 bar end"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")