re = /\bsection \d+ (?:(?!\bsection \d+).)*?(?:19|20)\d{2}\b/m
str = 'section 1 bar bar section 2 foo 2019 foo section 3 bar 2021 bar end'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end