#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\,\s*\}"
Local $sString = "(function(){" & @CRLF & _
" 'use strict';" & @CRLF & _
"" & @CRLF & _
" arpApp" & @CRLF & _
" .service('callControlService', ['$q', CallControlService]);" & @CRLF & _
"" & @CRLF & _
" function CallControlService($q){" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" // Promise-based API" & @CRLF & _
" return {" & @CRLF & _
" loadAllUsers : function() {" & @CRLF & _
" // Simulate async nature of real remote calls" & @CRLF & _
" return "test";" & @CRLF & _
" }," & @CRLF & _
" };" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
"})();" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")