import re
regex = re.compile(r"\,\s*\}")
test_str = ("(function(){\n"
" 'use strict';\n\n"
" arpApp\n"
" .service('callControlService', ['$q', CallControlService]);\n\n"
" function CallControlService($q){\n"
" \n\n"
" // Promise-based API\n"
" return {\n"
" loadAllUsers : function() {\n"
" // Simulate async nature of real remote calls\n"
" return \"test\";\n"
" },\n"
" };\n"
" }\n\n"
"})();\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")