const regex = /\,\s*\}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\,\\s*\\}', '')
const str = `(function(){
'use strict';
arpApp
.service('callControlService', ['\$q', CallControlService]);
function CallControlService(\$q){
// Promise-based API
return {
loadAllUsers : function() {
// Simulate async nature of real remote calls
return "test";
},
};
}
})();
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}