$re = '/\,\s*\}/';
$str = '(function(){
\'use strict\';
arpApp
.service(\'callControlService\', [\'$q\', CallControlService]);
function CallControlService($q){
// Promise-based API
return {
loadAllUsers : function() {
// Simulate async nature of real remote calls
return "test";
},
};
}
})();
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);