import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\,\\s*\\}";
final String string = "(function(){\n"
+ " 'use strict';\n\n"
+ " arpApp\n"
+ " .service('callControlService', ['$q', CallControlService]);\n\n"
+ " function CallControlService($q){\n"
+ " \n\n"
+ " // Promise-based API\n"
+ " return {\n"
+ " loadAllUsers : function() {\n"
+ " // Simulate async nature of real remote calls\n"
+ " return \"test\";\n"
+ " },\n"
+ " };\n"
+ " }\n\n"
+ "})();\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}