#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:(?:\+|00)971|9710)"
Local $sString = "009715012345" & @CRLF & _
"+9715012345" & @CRLF & _
"97105012345"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)