import re
regex = re.compile(r"^(?:(?:\+|00)971|9710)", flags=re.MULTILINE)
test_str = ("009715012345\n"
"+9715012345\n"
"97105012345")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)