const regex = /^(?:(?:\+|00)971|9710)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:\\+|00)971|9710)', 'gm')
const str = `009715012345
+9715012345
97105012345`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);