re = /^(?:(?:\+|00)971|9710)/m
str = '009715012345
+9715012345
97105012345'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result