$re = '/^(?:(?:\+|00)971|9710)/m';
$str = '009715012345
+9715012345
97105012345';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;