re = /[cf]=("[ a-zA-Z0-9_\/-]+\.(js|html)")/
str = '<script src="foo.js"...
<link rel="import" href="bar.html"...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end