// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"[cf]=("[ a-zA-Z0-9_/-]+\.(js|html)")"#).unwrap();
let string = "<script src=\"foo.js\"...
<link rel=\"import\" href=\"bar.html\"...";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}