using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!$)(?:<from>""([\d\-.]*)"")?(?:<to>""([\d\-.]*)"")?$";
string input = @"<from>""50""<to>""
<from>""<to>""60""
<from>""50""<to>""60""
<from>""<to>""60""
<to>""60""
<from>""50""
<to>""-5.5""<from>""-0.25""
9
""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}