import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!$)(?:<from>\"([\\d\\-.]*)\")?(?:<to>\"([\\d\\-.]*)\")?$";
final String string = "<from>\"50\"<to>\"\"\n"
+ "<from>\"\"<to>\"60\"\n"
+ "<from>\"50\"<to>\"60\"\n"
+ "<from>\"\"<to>\"60\"\n"
+ "<to>\"60\"\n"
+ "<from>\"50\"\n\n"
+ "<to>\"-5.5\"<from>\"-0.25\"\n"
+ "9\n"
+ "\"\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}