import Foundation
let pattern = #"^(?!$)(?:<from>"([\d\-.]*)")?(?:<to>"([\d\-.]*)")?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<from>"50"<to>""
<from>""<to>"60"
<from>"50"<to>"60"
<from>""<to>"60"
<to>"60"
<from>"50"
<to>"-5.5"<from>"-0.25"
9
""
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)