$re = '/^(?!$)(?:<from>"([\d\-.]*)")?(?:<to>"([\d\-.]*)")?$/m';
$str = '<from>"50"<to>""
<from>""<to>"60"
<from>"50"<to>"60"
<from>""<to>"60"
<to>"60"
<from>"50"
<to>"-5.5"<from>"-0.25"
9
""
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);