#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?msi)(?<=###(.*?)@@@.*?)&&&[a-z]+\^\^\^"
Local $sString = "STARTOFTEXT" & @CRLF & _
"&&&Aragorn^^^" & @CRLF & _
"###The Shire@@@" & @CRLF & _
"&&&Frodo^^^" & @CRLF & _
"&&&Bilbo^^^" & @CRLF & _
"&&&Pippin^^^" & @CRLF & _
"###Gondor@@@" & @CRLF & _
"&&&Faramir^^^" & @CRLF & _
"&&&Boramir^^^" & @CRLF & _
"ENDOFTEXT"
Local $sSubst = "$0 is from $1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)