const regex = /(?<=###(.*?)@@@.*?)&&&[a-z]+\^\^\^/gmsi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=###(.*?)@@@.*?)&&&[a-z]+\\^\\^\\^', 'gmsi')
const str = `STARTOFTEXT
&&&Aragorn^^^
###The Shire@@@
&&&Frodo^^^
&&&Bilbo^^^
&&&Pippin^^^
###Gondor@@@
&&&Faramir^^^
&&&Boramir^^^
ENDOFTEXT`;
const subst = `$0 is from $1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);