$re = '/(?<=###(.*?)@@@.*?)&&&[a-z]+\^\^\^/msi';
$str = 'STARTOFTEXT
&&&Aragorn^^^
###The Shire@@@
&&&Frodo^^^
&&&Bilbo^^^
&&&Pippin^^^
###Gondor@@@
&&&Faramir^^^
&&&Boramir^^^
ENDOFTEXT';
$subst = "$0 is from $1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;