use strict;
my $str = 'STARTOFTEXT
&&&Aragorn^^^
###The Shire@@@
&&&Frodo^^^
&&&Bilbo^^^
&&&Pippin^^^
###Gondor@@@
&&&Faramir^^^
&&&Boramir^^^
ENDOFTEXT';
my $regex = qr/(?<=###(.*?)@@@.*?)&&&[a-z]+\^\^\^/msip;
my $subst = '$0 is from $1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";