re = /(?<=###(.*?)@@@.*?)&&&[a-z]+\^\^\^/mi
str = 'STARTOFTEXT
&&&Aragorn^^^
###The Shire@@@
&&&Frodo^^^
&&&Bilbo^^^
&&&Pippin^^^
###Gondor@@@
&&&Faramir^^^
&&&Boramir^^^
ENDOFTEXT'
subst = '$0 is from $1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result