# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<span class='customer)(' id='phone[^>]*>)([^<]+)/$1 NewClass$2Organization/g;t' <<< "GIVEN:
<div>
<span class='customer' id='phone$0'>Home</span>
<br/>
<span class='customer' id='phone$1'>Business</span>
<br/>
<span class='customer' id='phone$2'>Mobile</span>
</div>
DESIRED:
<span class='customer NewClass' id='phone$1'>Organization</span>
"