const regex = /(<span class='customer)(' id='phone[^>]*>)([^<]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<span class=\'customer)(\' id=\'phone[^>]*>)([^<]+)', 'g')
const str = `GIVEN:
<div>
<span class='customer' id='phone\$0'>Home</span>
<br/>
<span class='customer' id='phone\$1'>Business</span>
<br/>
<span class='customer' id='phone\$2'>Mobile</span>
</div>
DESIRED:
<span class='customer NewClass' id='phone\$1'>Organization</span>
`;
const subst = `$1 NewClass$2Organization`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);