using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<span class='customer)(' id='phone[^>]*>)([^<]+)";
string substitution = @"$1 NewClass$2Organization";
string input = @"GIVEN:
<div>
<span class='customer' id='phone$0'>Home</span>
<br/>
<span class='customer' id='phone$1'>Business</span>
<br/>
<span class='customer' id='phone$2'>Mobile</span>
</div>
DESIRED:
<span class='customer NewClass' id='phone$1'>Organization</span>
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}