package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<span class='customer)(' id='phone[^>]*>)([^<]+)`)
var str = `GIVEN:
<div>
<span class='customer' id='phone$0'>Home</span>
<br/>
<span class='customer' id='phone$1'>Business</span>
<br/>
<span class='customer' id='phone$2'>Mobile</span>
</div>
DESIRED:
<span class='customer NewClass' id='phone$1'>Organization</span>
`
var substitution = "$1 NewClass$2Organization"
fmt.Println(re.ReplaceAllString(str, substitution))
}