#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\d+\.?\d*"
Local $sString = "Rate: 102.9" & @CRLF & _
"Rate: 44" & @CRLF & _
"Rate: 00" & @CRLF & _
"Rate: 113.1" & @CRLF & _
"Rate: 43" & @CRLF & _
"Rate: 33.3" & @CRLF & _
"Rate: 00" & @CRLF & _
"Rate: 15"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")