using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+\.?\d*";
string input = @"Rate: 102.9
Rate: 44
Rate: 00
Rate: 113.1
Rate: 43
Rate: 33.3
Rate: 00
Rate: 15";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}