$re = '/\d+\.?\d*/';
$str = 'Rate: 102.9
Rate: 44
Rate: 00
Rate: 113.1
Rate: 43
Rate: 33.3
Rate: 00
Rate: 15';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);