package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d+\.?\d*`)
var str = `Rate: 102.9
Rate: 44
Rate: 00
Rate: 113.1
Rate: 43
Rate: 33.3
Rate: 00
Rate: 15`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}