import Foundation
let pattern = #"\d+\.?\d*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Rate: 102.9
Rate: 44
Rate: 00
Rate: 113.1
Rate: 43
Rate: 33.3
Rate: 00
Rate: 15
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)