package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\s*,{1}\s*)`)
var str = `He went home 2013 , Juni , October 5 ,19:30
He went home 2013, Juni , October 5 , 19:30
He went home 2013 , Juni, October 5, 19:30
He went home 2013,,,Juni, October 5,19:30`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}