import Foundation
let pattern = #"(\s*,{1}\s*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
He went home 2013 , Juni , October 5 ,19:30
He went home 2013, Juni , October 5 , 19:30
He went home 2013 , Juni, October 5, 19:30
He went home 2013,,,Juni, October 5,19:30
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)