$re = '/(\s*,{1}\s*)/';
$str = 'He went home 2013 , Juni , October 5 ,19:30
He went home 2013, Juni , October 5 , 19:30
He went home 2013 , Juni, October 5, 19:30
He went home 2013,,,Juni, October 5,19:30';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);