re = /(\s*,{1}\s*)/
str = 'He went home 2013 , Juni , October 5 ,19:30
He went home 2013, Juni , October 5 , 19:30
He went home 2013 , Juni, October 5, 19:30
He went home 2013,,,Juni, October 5,19:30'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end