import re
regex = re.compile(r"(\s*,{1}\s*)")
test_str = ("He went home 2013 , Juni , October 5 ,19:30\n\n"
"He went home 2013, Juni , October 5 , 19:30\n\n"
"He went home 2013 , Juni, October 5, 19:30\n"
"He went home 2013,,,Juni, October 5,19:30")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")