using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([_-]?[a-z][_-]?[1-9][_-]?[a-z][_-]?)";
string input = @"
2222ab4053bcd4324abcd8877
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}