$re = '/([_-]?[a-z][_-]?[1-9][_-]?[a-z][_-]?)/i';
$str = '
2222ab4053bcd4324abcd8877
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);