re = /([_-]?[a-z][_-]?[1-9][_-]?[a-z][_-]?)/i
str = '
2222ab4053bcd4324abcd8877
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end