package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)([_-]?[a-z][_-]?[1-9][_-]?[a-z][_-]?)`)
var str = `
2222ab4053bcd4324abcd8877
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}